Pre-Winter Limited Time 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: agile70

ExamsBrite Dumps

Splunk Certified Cybersecurity Defense Engineer Question and Answers

Splunk Certified Cybersecurity Defense Engineer

Last Update Oct 12, 2026
Total Questions : 105

We are offering FREE SPLK-5002 Splunk exam questions. All you do is to just go and sign up. Give your details, prepare SPLK-5002 free exam questions and then go for complete pool of Splunk Certified Cybersecurity Defense Engineer test questions that will help you more.

SPLK-5002 pdf

SPLK-5002 PDF

$31.5  $104.99
SPLK-5002 Engine

SPLK-5002 Testing Engine

$37.5  $124.99
SPLK-5002 PDF + Engine

SPLK-5002 PDF + Testing Engine

$49.5  $164.99
Questions 1

Which of the following is the most efficient search to return a list of all visible indexes and the sourcetypes contained within them?

Options:

A.  

A raw-event search followed by aggregation.

B.  

A non-index-grouped metadata search.

C.  

An index=* event search followed by stats.

D.  

A tstats search returning sourcetypes and grouping them by index.

Discussion 0
Questions 2

Which of the following macro values will exclude all of the company networks if it is called from the following search?

index=firewall sourcetype=pan\:traffic NOT " company_networks "

Options:

A.  

(src_ip IN (151.157.30.0/24, 26.06.18.0/24))

B.  

NOT (src_ip IN (151.157.30.0/24, 26.06.18.0/24))

C.  

NOT (src_ip=151.157.30.0/24 AND src_ip=26.06.18.0/24)

D.  

(src_ip=151.157.30.0/24 AND src_ip=26.06.18.0/24)

Discussion 0
Questions 3

An engineer needs to create a new report capturing the vendors and products that detect a particular CVE in their environment. How can they ensure that the search associated with the report only includes accelerated data?

Options:

A.  

Search vendor_product within the Vulnerabilities data model using a standard search.

B.  

Search the Updates data model for vendor/product information.

C.  

Search for the CVE within the Vulnerabilities data model using tstats, grouped by vendor_product.

D.  

Search vendor_product within the Updates data model using tstats.

Discussion 0
Questions 4

Which of the following should be the primary reference when designing a new playbook in Splunk SOAR?

Options:

A.  

Existing investigation actions

B.  

MITRE ATT & CK® framework

C.  

Existing Standard Operating Procedure

D.  

CIS Framework

Discussion 0
Questions 5

In Enterprise Security, what is the name of the threat intelligence lookup pertaining to files?

Options:

A.  

file_hash

B.  

file_intel

C.  

user_intel

D.  

user_hash

Discussion 0
Questions 6

An engineer is writing a correlation search and needs to use T1059 from MITRE ATT & CK as a field in Incident Review. Assuming they are writing a correlation search that does not use the Risk data model, which example statement should be appended to the correlation search?

Options:

A.  

The expression assigning T1059 to the correlation search ' s MITRE ATT & CK annotation field.

B.  

The expression assigning T1059 to an unrelated event field.

C.  

The expression applying T1059 only through a risk-model field.

D.  

The expression using a non-annotation field for the ATT & CK technique.

Discussion 0
Questions 7

The SOC manager has a desire to measure mean time to acknowledge finding (notable event) in order to meet a desired service-level objective. Which two fields can be used to measure the difference?

Options:

A.  

Status, Owner

B.  

Urgency, Status

C.  

Severity, Owner

D.  

User, Status

Discussion 0
Questions 8

Risk scores are associated with how many levels of risk in Enterprise Security by default?

Options:

A.  

(4) Info, Medium, High, Critical

B.  

(3) Low, Medium, High

C.  

(5) Info, Low, Medium, High, Critical

D.  

(6) Info, Low, Medium, High, Critical, Unknown

Discussion 0
Questions 9

Which Splunk Enterprise Security add-on facilitates the ingestion of Threat Intelligence data?

Options:

A.  

TA-ThreatIntel

B.  

ESS-Intel

C.  

SA-ThreatIntelligence

D.  

SA-ESSIntel

Discussion 0
Questions 10

What is a key feature of effective security reports for stakeholders?

Options:

A.  

High-level summaries with actionable insights

B.  

Detailed event logs for every incident

C.  

Exclusively technical details for IT teams

D.  

Excluding compliance-related metrics

Discussion 0
Questions 11

The following SPL is designed to report on a certain SOC metric. Which metric is the most likely topic for this report?

| tstats summariesonly=true earliest(_time) as _time

FROM datamodel=Incident_Management

BY " Notable_Events.Meta.rule_id "

| rename " Notable_Events.Meta.* " as " * "

| lookup update=true incident_updates_lookup rule_id OUTPUTNEW time

| search time=*

| stats earliest(_time) as create_time, min(time) as triage_time by rule_id

| eval diff=triage_time-create_time,

stat_type=if(

create_time < relative_time(now(), " -7d@d " ),

" past " ,

" current "

),

past=if(stat_type= " past " , 1, 0),

current=if(stat_type= " current " , 1, 0),

past_diff=if(stat_type= " past " , diff, 0),

current_diff=if(stat_type= " current " , diff, 0)

| stats sum(past) AS past,

sum(current) AS current,

sum(past_diff) AS past_diff,

sum(current_diff) AS current_diff

| eval past=round(past_diff/past/60),

current=round(current_diff/current/60)

| table past, current

| transpose

Options:

A.  

Mean time to Triage

B.  

Mean time to Respond

C.  

Mean time to Resolve

D.  

Dwell Time

Discussion 0
Questions 12

What field is used by default to direct data into CIM data model datasets?

Options:

A.  

tag

B.  

sourcetype

C.  

source

D.  

dataset

Discussion 0
Questions 13

When setting Common Information Model (CIM) accelerations, which parameter should be defined to set how far back in time (specified as a relative time string) the Splunk platform creates its column stores?

Options:

A.  

Max summarization search time

B.  

Backfill range

C.  

Accelerate until maximum time

D.  

Summary range

Discussion 0
Questions 14

Which REST call will show a list of alerts with their specific commands, app, and title?

Options:

A.  

| rest /servicesNS/admin/-/alerts/alert_actions

| table title, eai:acl.app, label, payload_format, command

B.  

| rest /servicesNS/user/-/alerts/alert_actions

| table title, eai:acl.app, label, payload_format, command

C.  

| rest /servicesNs/admin/-/actions/alert_actions

| table title, eai:acl.app, label, payload_format, command

D.  

| rest /servicesNS/user/-/actions/alert_actions

| table title, eai:acl.app, label, payload_format, command

Discussion 0
Questions 15

Which syntax is correct to create two new rows on an existing threat intelligence collection?

Options:

A.  

curl -k -u admin\:pass https://localhost:8089/services/data/threat_intel/item/email_intel -d item= ' [{ " src_user " : " user_new " , " subject " : " click this " },{ " src_user " : " user2_new " , " subject " : " click this " }] ' -G -X

B.  

curl -k -u admin\:pass https://localhost:8089/services/data/threat_intel/item/email_intel -d item= ' [{ " src_user " : " user_new " , " subject " : " click this " }] '

C.  

curl -k -u admin\:pass https://localhost:8089/services/data/threat_intel/item/email_intel -d item= " [{ " src_user " : " user_new " , " subject " : " click this " },{ " src_user " : " user2_new " , " subject " : " click this " }] "

D.  

curl -k -u admin\:pass https://localhost:8089/services/data/threat_intel/item/email_intel -d item= ' [{ " src_user " : " user_new " , " subject " : " click this " }] ' -G -X

Discussion 0
Questions 16

A detection engineer is using a threat defense informed strategy to define use cases. Which Splunk app would best facilitate their use case development process by cross referencing detections with the MITRE ATT & CK Framework?

Options:

A.  

Supporting add-on for MITRE ATT & CK

B.  

Splunk Security Essentials App

C.  

Enterprise Security

D.  

Enterprise Security Content Update App

Discussion 0
Questions 17

MITRE D3FEND is designed to compliment MITRE ' s list of adversarial tactics, techniques, and common knowledge (ATT & CK). Which tactics are associated with MITRE D3FEND in order to detect, deny, and disrupt adversarial efforts?

Options:

A.  

Harden, Detect, Exclude, Deceive, Eradicate

B.  

Harden, Detect, Isolate, Disrupt, Evict

C.  

Harden, Detect, Exclude, Define, Eradicate

D.  

Harden, Detect, Isolate, Deceive, Evict

Discussion 0
Questions 18

A SOC ' s Incident Response Standard Operating Procedure (SOP) calls for any phishing emails containing files to be detonated in Splunk Attack Analyzer for evaluation. Which of the following can an engineer implement to gain efficiency through automation?

Options:

A.  

Automatically assign phishing-tagged findings to analysts to begin manual collection.

B.  

Automatically send an email notification for all findings containing the phishing tag.

C.  

Use a SOAR playbook to handle the Splunk Attack Analyzer submission and data-collection steps and make the information available to an assigned analyst.

D.  

Use a SOAR playbook to submit the email to PhishTank and have it perform the Splunk Attack Analyzer submission.

Discussion 0
Questions 19

Which of the following can process data from configured containers using an automated sequence of actions?

Options:

A.  

Cases

B.  

Workbooks

C.  

Containers

D.  

Playbooks

Discussion 0
Questions 20

An engineer notices that a detection is creating multiple Findings (notables) for the same potential incident. Which setting can be adjusted to reduce the number of generated findings (notables)?

Options:

A.  

Correlation search throttling

B.  

Correlation search priority

C.  

Adaptive risk modifier

D.  

Adaptive response actions

Discussion 0
Questions 21

How does Mission Control decipher which response template to assign to findings?

Options:

A.  

This is determined when creating a detection in ES, which gets carried over to Mission Control.

B.  

Mission Control uses AI to decipher which response templates are assigned.

C.  

Response templates are assigned to specific incident types.

D.  

The only way to configure this is with SOAR.

Discussion 0
Questions 22

An EDR tool was recently purchased and needs to be integrated into existing Splunk SOAR playbooks. Which actions are typically associated with this type of asset?

Options:

A.  

Block device, remove email, detonate URL, get indicator

B.  

Block hash, block process, quarantine device, get indicator

C.  

Block URL, block subdomain, quarantine device, get indicator, detonate URL

D.  

Block hash, reset user password, quarantine device, get indicator

Discussion 0
Questions 23

An engineer has been working on building a new automation for the SOC. What Scope should be selected in the SOAR Playbook Debugger during the playbook development to ensure consistency?

Options:

A.  

New Events

B.  

All Artifacts

C.  

New Artifacts

D.  

All Events

Discussion 0
Questions 24

What is one method used in ESCU content to calculate a risk score when creating a detection that uses the Risk Analysis adaptive response action?

Options:

A.  

Risk Score = (Impact × Confidence / 100)

B.  

Risk Score = (Risk Object Severity × Confidence / 100)

C.  

Risk Score = (Risk Object Priority × Confidence / 100)

D.  

Risk Score = (Impact × Priority / 100)

Discussion 0
Questions 25

What does the following search do?

source=WinEventLog:security* sourcetype= " WinEventLog* " EventCode=4688

| stats count, values(process) as process by parent_process_name

Options:

A.  

Displays a count of processes created by the same user.

B.  

Displays a list of newly created processes and the user that created them.

C.  

Displays a count of processes created by the same child process.

D.  

Displays a list of processes and their parent processes.

Discussion 0
Questions 26

Which tool can help identify known tactics, techniques, and procedures that a threat group is most likely to use when targeting a financial organization?

Options:

A.  

The MITRE ATT & CK® Posture panel within Mission Control ' s Incident Review page

B.  

The MITRE ATT & CK® matrix ' s industry heatmap in Splunk Security Essentials

C.  

The Lockheed Martin Cyber Kill Chain® Posture panel within Enterprise Security ' s Incident Review page

D.  

Splunk Threat Intelligence Management

Discussion 0
Questions 27

Which Splunk feature makes SPL searches shorter and reusable by inserting it into search strings?

Options:

A.  

Knowledge objects

B.  

Commands

C.  

Lookups

D.  

Macros

Discussion 0
Questions 28

In a Risk-Based Alerting implementation with Splunk Enterprise Security, which of the following best describes a risk factor?

Options:

A.  

A multiplier of risk that depends on the characteristics of the specific user or asset.

B.  

An event that modifies risk based on the characteristics of the specific user or asset.

C.  

A tool to enable risk data model acceleration.

D.  

A SOAR action that is drawn from annotations.

Discussion 0
Questions 29

Consider the following series of events:

4:00 GMT Detection runs for interval 3:30–4:00

4:30 GMT Detection runs for interval 4:00–4:30

4:35 GMT Event 1 occurs on an endpoint

4:45 GMT Event 1 is indexed

5:00 GMT Detection runs for interval 4:30–5:00

5:05 GMT Event 1 finding is added to ES with timestamp 4:35

5:24 GMT Event 2 occurs on an endpoint

5:30 GMT Detection runs for interval 5:00–5:30

5:35 GMT Event 2 is indexed

6:00 GMT Detection runs for interval 5:30–6:00

What is the problem with the detection schedule chosen and how can it be solved?

Options:

A.  

The logs are delayed so the detection time window needs to be decreased.

B.  

The time window for the detection is too small, causing duplicate alerts.

C.  

The time window for the detection is too large, causing duplicate alerts.

D.  

The logs are delayed so the detection time window needs to be increased.

Discussion 0
Questions 30

When creating a detection, how might an engineer ensure that all possible contextual fields about a given asset and identity are added to a risk event?

Options:

A.  

Include the standard CIM fields for assets and identities in the detection output.

B.  

Use an identity lookup to return all available identity information in the detection output.

C.  

Use an asset lookup to return all available asset information in the detection output.

D.  

Call an Active Directory adaptive response action to perform a real-time update.

Discussion 0
Questions 31

A detection engineer is using a threat defense informed strategy to define use cases. Which Splunk app would best facilitate their use case development process by cross referencing detections with the MITRE ATT & CK Framework?

Options:

A.  

Enterprise Security Content Update App

B.  

Splunk Security Essentials App

C.  

Enterprise Security

D.  

Supporting add-on for MITRE ATT & CK

Discussion 0